Problem z WiFi (Asus WL138G V2 + Vista)

Z zakresu krótkich rozwiązań sprecyzowanych problemów ostatnio dosyć ciekawym zadaniem stało się stworzenie sieci WiFi za pomocą wspomnianej wyżej karty (koszt to 49zł, a więc całkiem tanio) oraz systemu Windows Vista. Okazuje się że dla osoby niezbyt zorientowanej w tych tematach, poszukiwanie rozwiązania jest karkołomne, bowiem problem ma tutaj dwie płaszczyzny: systemową i sprzętową – system który ma kłopot z poprawnym odnajdywaniem DHCP oraz kartę która pokazuje maksymalną moc sygnału a gubi go w odległości 50cm od karty docelowej, działając przy tym sezonowo i bardzo wolno.

Jeśli więc ktoś z Was spotkał się chociażby z niemożnością stworzenia np. prostego połączenia typu ad-hoc na tym systemie (lub Windows 7 – z tym że w obu przypadkach na wersjach 32-bitowych) i tej konkretnej karcie, prawdopodobnie od tej pory będzie mógł to zrobić.. mam nadzieję.

 

Poprawiamy Vistę – ręcznie lub automatycznie

Esencję problemu od strony software’owej wyjaśnia cytat: „(…) w systemie Windows Vista flaga BROADCAST w pakietach odnajdywania DHCP nie jest wyłączona. Dlatego niektóre routery i serwery DHCP firm innych niż Microsoft nie mogą przetworzyć odnajdywania DHCP.
W zasadzie całość czynności została opisana na stronie Microsoft pod TYM adresem, więc nie będę się zbytnio tutaj rozwodził (pomoc jest tam napisana po polsku).
Powiem tylko że oba sposoby przetestowałem działają perfekcyjnie, także sugeruję posłużyć się fixem – będzie szybciej. Zabieramy się więc teraz za kartę i jeśli to z nią i tylko z nią macie problem (tj. posiadacie Windows 7 na przykład), naprawę można rozpocząć dopiero od tego momentu.

.
Poprawiamy… Asusa

Jak się okazuje, karta Asusa jest oparta o układ z serii 43 (43xx) marki Broadcom. Asus z kolei udostępnia sterowniki do swojej karty z datą… 2006-2007. Trudno więc aby działała prawidłowo w takich okolicznościach – a działa tak jakby nie działała.

 

.

.

Objawy są następujące:
– cały czas najwyższa siła sygnału,
– jednoczesna niemożność połączenia się z routerem (monit: sygnał zbyt słaby lub router nie odpowiada),
– ogromne problemy z nawiązaniem łączności z drugim komputerem przez ad-hoc, nawet w minimalnej odległości,
– „gubione” co rusz otoczenie sieciowe,
– bardzo zaniżona przepustowość w statusie łącza i skrajnie niski transfer danych.

Jeśli macie system Windows Vista / 7 w wersji 32bit (ew. XP, choć nie wiem na 100% czy zadziałają), ściągnijcie TE sterowniki.
Są one z końca stycznia 2009 roku, więc o wiele nowsze od oryginalnych. Po ich instalacji (nie trzeba deinstalować poprzednich, restart nie jest wymagany) zmieni się jedynie nazwa karty sieciowej z Asus na Broadcom, ważniejsze jednak że wszystko powinno wrócić do normy i sieć wreszcie powinna dać się używać z pełną przepustowością i zasięgiem (oczywiście jeśli nie ma żadnych rzeczy rozpraszających sygnał).